Forums - Galil: We Move The World
Topic Options
#11328 - 11/30/11 03:23 PM Manual Tuning, KP=0
smkelly Offline
Junior Member

Registered: 11/30/11
Posts: 2
I'm trying to manually tune my stages (when i use the automatic tuning routines in WSDK, the stages shake like crazy). Anyway, what i have read about manually tuning indicates setting KP and KI equal to zero and increase KD until a step move generates oscillation. When i set KP=0, and KD=5, the axis does not move. If i set KP=0.125, i can get KD to go to 4000 without oscillation (it overshoots, but does not oscillate). Is the KP not being set to zero messing with this technique?

Also, the reason i am tuning the stages is because after an hour of repetitive moves, the stages begin to "chatter". With my current settings of KD=5, KP=1.5 and KI=0.01, the stages will not chatter at startup. Would you recommend trying to tune after things have warmed up a bit?

Controller is DMC-18x2 series.



#11335 - 12/01/11 04:41 PM Re: Manual Tuning, KP=0 [Re: smkelly]
AndyH Offline


Registered: 12/20/05
Posts: 583
Loc: Rocklin, CA

Often while manual tuning it is better to have KP set to a non-zero value while increasing the KD term. I typically like to keep at least a 100:1 ratio between the 2 when increasing KD. So start with KD 10 and KP0.1, when you get to KD 20, increase KP to 0.2 until you find the max for KD. After that increase KP, then get rid of steady state error with KI.

I would also recommend setting up a basic move while you are performing the tuning. This will allow you to see the response to an actual move while you are adjusting the parameters.
Andy Herum
Senior Applications Engineer
Galil Motion Control

#13891 - 09/01/14 06:09 PM Re: Manual Tuning, KP=0 [Re: smkelly]
lolgamegd01 Offline
Junior Member

Registered: 09/01/14
Posts: 4
I am very optimistic about you made the post.
And I like.
I hope we can become friends, thank you!

Here is my ESO Gold will sent to you.


Moderator:  CoryB